Elibean's Patreon

Announcement

Collapse
No announcement yet.

Formatting not preserved correctly when pasting from word processors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Formatting not preserved correctly when pasting from word processors

    I'm on Windows 8.1, using Firefox 60.0.1 (64bit)

    I type everything up in Scrivener and then compile into another format for posting. I converted to html for the vB4 version of the forums, but this no longer works as everything gets screwed up.

    Per ClawdiaWolf's suggestion on IRC, I compiled the project to .rtf, opened in Wordpad, and copied from there. No formatting is preserved at all when doing so.
    I also tried compiling to .doc, .docx, and .odt. Then, copying from LibreOffice, I pasted using the "Paste from Word" button. That worked fine for proper line spacing, italics, bold, and underline, but loses centering even though centered paragraphs appear correctly in the preview window (the preview when actually using the "paste from word," not the preview post window.

    Am I fouling something up here?
    I know it's kinda trivial, but I like centering my scene breaks and titles and whatever. Going through a large story re-centering every single one is rather tedious and I'd like to find a way to avoid doing so if possible.
    The voices in my head got weirded-out and left long ago.

    #2
    Well considering how many people have copy and pasted stories since the upgrade from several word processors, and yes from Scrivener as well using the exact steps I gave you on IRC (I should know on that one as I am using that method) without issues I'm going to have to assume it is an issue on your end.

    In fact, the #1 issue I'm dealing with regularly right now? Fixing the copy and pasted code from hell that is getting generated because I can't fix it the way I did on vb4!

    If the paste from word button is working, then it sounds like something else is broken on your end as that button should actually not be preserving any formatting except paragraph breaks.

    Comment


      #3
      Oh, wait. Just saw your OS. That would explain why the RTF isn't working. Using a .odt file should work properly though. There's literally no reason it shouldn't preserve the centering.

      EDIT: Send me a PM on here and copy and paste a small part of what's not centering properly for you. Do this when sending it [nocode]<paste here>[/nocode]

      That will let me see on my end the exact code the board thinks is being submitted.

      Comment

      Working...
      X