Announcement

Collapse
No announcement yet.

strange error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    strange error

    I got this the other day, and again today - twice in a row:
    https://imgur.com/a/s8xsEh3

    Clicking on the 'inform the administrator' link tries to take me to https://abdlstoryforum.info/%1$s which reports a HTTP 400 error.

    To replicate this I, erm, just leave my browser open. It does seem to occur a few seconds after I refresh the page, but not immediately the page loads. Always happens on the page shown.

    #2
    Sorry, but I'm not clicking on random Imgur links. If you want to report an issue with a screenshot please upload the screenshot to the board itself.
    I GET KNOCKED DOWN BUT I GET UP AGAIN!

    Comment


      #3

      Comment


        #4
        Ah, that error. It happens when the CSRF session token expires. It's caused by the background thread that checks for notifications when the cookie that stores the session token no longer matches the one the board is expecting.

        Not sure why the link would be broken. That's a core error message so it shouldn't be possible for it to generate an invalid link. It's supposed to link to the contact form. I'll take a look at it the next time I'm logged into the shell.
        I GET KNOCKED DOWN BUT I GET UP AGAIN!

        Comment


          #5
          Oh boy, I see what has happened with the link now.

          The 400 error is because of mod_security blocking what it thinks is a SQL injection attack. Not sure why it thinks that, but there it is.

          Unfortunately the reason that link is breaking is problematic as it isn't as easily fixed as I would like due to why it is happening. Looking into a couple of possible fixes that won't cause issues with future updates.

          EDIT: Temporary fix in place.
          Last edited by Penguin; 04-03-2019, 04:18:41 AM.
          I GET KNOCKED DOWN BUT I GET UP AGAIN!

          Comment

          Working...
          X